What is Frame Relay Subinterfaces? Explained with Example

By | 9th November 2015

How To Configure Frame Relay Subinterfaces.

In Frame Relay network connection, a physical interface can be divided into multiple virtual interfaces; this is referred to as subinterfaces.

A subinterface is simply a logical interface that is directly linked with a physical interface. Therefore, a Frame Relay subinterface can be configured for each of the PVCs coming into a physical serial interface.

Using a Frame Relay point-to-point sub-interface option was created to avoid split horizon issues. In split horizon routing environments, routing updates received on one subinterface can be sent out another subinterface. In a subinterface configuration, each VC can be configured as a point-to-point connection. This allows each subinterface to act similarly to a leased line. Using a Frame Relay point-to-point subinterface, each pair of the point-to-point routers is on its own subnet.

Frame Relay subinterfaces can be configured in either point-to-point or multipoint mode:

i. Frame Relay point-to-point

A single point-to-point subinterface establishes one PVC connection to another physical interface or subinterface on a remote router placing them in their own subnet and each point-to-point subinterface has a single DLCI. In a point-to-point environment, each subinterface is acting like a point-to-point interface. Typically, there is a separate subnet for each point-to-point VC. Therefore, routing update traffic is not subject to the split horizon rule.

 ii. Multi-point.

A single multipoint subinterface establishes multiple PVC links to multiple physical interfaces or subinterfaces on remote routers and are all in the same subnet. The subinterface acts like an NBMA Frame Relay interface, so routing update traffic is subject to the split horizon rule. normally, all multipoint VCs belongs to the same subnet.

Example Topology:

In the topology below, router R1 has two point-to-point subinterfaces.

 1.  The s0/0.0.102 subinterface connects to R2, and the

 2.  The s0/0/0.103 subinterface connects to R3.

Each subinterface is on a different unique subnet.

frame relay sub

How to Configure Frame Relay Subinterface on Cisco router

R1 to R2

R1(config)#interface se0/0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shutdown

R1(config)#interface se0/0/0.102 point-to-point

R1(config-if)#ip address 10.2.1.1 255.255.255.252

R1(config-subif)#frame-relay interface-dlci 102

R1(config-subif)#end

R1(config-if)#exit

R1 to R3

R1(config)#interface se0/0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shutdown

R1(config)#interface se0/0/0.103 point-to-point

R1(config-if)#ip address 10.2.1.5 255.255.255.252

R1(config-subif)#frame-relay interface-dlci 103

R1(config-subif)#end

Step to configure Frame Relay subinterfaces on a physical interface:

Step 1. Remove any network layer address (IP) assigned to the physical interface. If the physical interface has an address, frames are not received by the local subinterfaces.

Step 2. Configure Frame Relay encapsulation on the physical interface using the encapsulation frame-relay command.

Step 3. For each of the defined PVCs, create a logical subinterface. Specify the port number, followed by a period (.) and the subinterface number. To make troubleshooting easier, it is suggested that the subinterface number matches the DLCI number.

Step 4. Configure an IP address for the interface and set the bandwidth.

Step 5. Configure the local DLCI on the subinterface using the frame-relay interface-dlci command.

Frame Relay address mapping

How Frame Relay works

How to Configure Frame Relay on Cisco Router

Troubleshooting Frame Relay configuration

Host Standby Router Redundancy Protocol (HSRP)

Virtual Router Redundancy Protocol (VRRP)

Gateway Load Balancing Protocol (GLBP)

Spanning Tree Protocol (STP)

VLAN Trunking Protocol (VTP)

Leave a Reply

Your email address will not be published. Required fields are marked *