How to Configure InterVLAN Routing Example

By | 9th November 2015

Configuring InterVLAN routing on Cisco Router.

When configuring InterVLAN routing, it’s advisable you firstly, configure the switch SW1 that will be connected to the router, as shown in the diagram.

 Router R1 is connected to switch ports F0/4 and F0/3, which have been configured for VLANs 10 and 20, respectively.

intervlan config

Example of switch SW1 interface configuration command:

SW1#config t

SW1(config)#vlan 10

SW1(config-vlan)#vlan 20

SW1(config-vlan)#exit

SW1(config)#interface fa0/8

SW1(config-if)#switchport access vlan 10

SW1(config-if)#interface fa0/4

SW1(config-if)#switchport access vlan 10

SW1(config-if)#interface fa0/11

SW1(config-if)#switchport access vlan 20

SW1(config-if)#interface fa0/3

SW1(config-if)#switchport access vlan 20

SW1(config-if)#end

#SYS-5-CONFIG_I: configured from console by console

SWI#

In the above example, interfaces F0/4 and F0/8 has been configured on VLAN 10 using the switchport access vlan 10 command. The same process is used to assign VLAN 20 to interface F0/3 and F0/11 on switch SW1.

To be on a safe side use the copy running-config startup-config command in privileged EXEC mode to save your configuration

Example of router R1 interface configuration command:

R1#config t

R1(config)#interface fa0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shut

….

R1(config-if)#interface fa0/1

RI(config-if)#ip address 192.168.2.1 255.255.255.0

RI(config-if)#no shut

RI(config-if)#end

As shown in the figure above, each router interface – fa0/0 and fa0/1 – belong to a different subnet and is configured with an ip address and subnet mask in the interface configuration mode, and no shutdown command is used to enable the router interface.

After the no shutdown is issued in interface configuration mode, you will notice a display indicating that the interface state has changed to up. This indicates that the interface is now enabled.

You can examine the routing table using the show ip route privileged EXEC mode command. This command displays the locally connected interfaces of the router.

You can also use the show interface command in privileged EXEC mode to view more detailed information about the router interfaces, such as diagnostic information, status, MAC address, and transmit or receive errors,

In summary:

If the router receives a packet on interface F0/0 destined for the 192.168.2.0 subnet, the router would identify that it should send the packet out via interface F0/1 to reach hosts on the 192.168.2.0 subnet.

Router-on-a-Stick Inter-VLAN Routing

How to Configure IPv6 Static and Default Routes.

Host Standby Router Redundancy Protocol (HSRP)

Virtual Router Redundancy Protocol (VRRP)

Gateway Load Balancing Protocol (GLBP)

Spanning Tree Protocol (STP)

VLAN Trunking Protocol (VTP)

IPv6 Explained

EIGRPv6

RIPv6 or RIPng

OSPFv3

DHCPv6

Leave a Reply

Your email address will not be published. Required fields are marked *