What is eBGP? Explained with Examples

By | 9th November 2015

External Border Gateway Protocol (eBGP) is a BGP term or process used when refering to BGP peers or neighbors that are in a different Autonomous System and Number (ASN).
In other words, eBGP is used to exchange route information between different autonomous systems. When only one link connects two autonomous systems, the IP addresses of the connected interfaces are used to establish a BGP session between the two. You can use any other IP address on the interfaces, but the address must be reachable without using internal Gateway Protocol IGP configuration.


There are basic needs to be met when using eBGP to inject routes owned by one Autonomous System (AS) through the enterprise network and into another AS, such as:

i,  A local router’s ASN must match the neighboring router’s reference to that ASN, also its neighbor remote-as asn command.

ii, The neigboring BGP router IDs must not be the same..

iii, Each BGP neighboring router must be part of a TCP connection with each other.  The remote or neighboring router’s IP address used in that TCP connection must match with the local router configuration in a BGP neighbor remote-as command.
Example topology:

ebgp

eBGP Configuration:

   Router 1  

R1>enable

R1#config t

R1(config)#interface se0/0/0

R1(config-if)#ip address 192.168.100.1 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#router bgp 556

R1(config-router)#neighbor 192.168.100.2 remote-as 255

R1(config-router)#end

R1#

Router 2

R2>enable

R2#config t

R2(config)#interface se0/0/0

R2(config-if)#ip address 192.168.100.2 255.255.255.252

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#router bgp 255

R2(config-router)#neighbor 192.168.100.1 remote-as 556

R2(config-router)#end

R2#

From the above configuration, R1 and R2 belong to different autonomous systems— 556 and 255, respectively.
The peer relationship between R1 and R2 in the above example is established because, R1 peering IP address is in the same subnet as its own physical interface.

When BGP neighbor are not directly connected, you will have to use the eBGP multihop command to establish connectivity.

iBGP Configuration

Multihop eBGP Sessions Configuration

How To Configure BGP using Loopback Address

How To Configure BGP Peers with Authentication

EIGRP

RIP v2

OSPF

Host Standby Router Redundancy Protocol (HSRP)

Virtual Router Redundancy Protocol (VRRP)

Gateway Load Balancing Protocol (GLBP)

Spanning Tree Protocol (STP)

VLAN Trunking Protocol (VTP)

IPv6 Explained

EIGRPv6

RIPv6 or RIPng

OSPFv3

DHCPv6

Leave a Reply

Your email address will not be published. Required fields are marked *